Direkt zum Seiteninhalt springen

Hallo,

hat jemand versucht, das heinzelnisse.jar mit gij (GNU Java Interpreter) zum laufen zu bringen?
Ich kriege ständig java.lang.VerifyError Exceptions, oder benötige ich Libraries, die nur im Sun Java Interpreter vorhanden sind?

Vielen Dank!
thomas

26.08.05 09:48
Hallo Thomas,

heinzelnisse.jar nutzt SwingAWT als Oberfläche, um die Downloads klein zu halten. Die gij Implementierung von AWTSwing ist sehr, sehr rudimentär. Da ich es zuletzt getestet haben (vor ca. 1Jahr) war der 10 Jahre alte AWT Befehlssatz noch nicht stabil implementiert, geschweige denn etwas neueres. Im Swing/AWT bereich ist der gij noch alpha-Qualität.

Du benötigst Libraries die in Java Version 1.3 (ich gehe gerade zu 1.4 über) enthalten sind. Ich habe es mit Sun, Blackdown, IBM und Bea Java Versionen erfolgreich getestet.

Heiko